DHCP server pre PXE enviroment – mikrotik alebo openwrt

Po dlhšom čase mám doma druhý počítač bez pevného disku a keďže by som ho rád nejako využil, rozhodol som sa sprevádzkovať na svojom desktope tftp server spolu s syslinux boot menu, nech je na niečo užitočný. Mám v pláne spojazdniť si nejakú slušnú distribúciu na diagnostiku pc (svojho času mi najviac vyhovovalo ubuntu 9.10, kde okrem všadeprítomného memtestu pri štarte na Vás hneď po naštartovaní systému vyskočila hláška s notifikačného panelu ohľadom nefunkčnosti HW periférie, či demón s.m.a.r.t. monitoringu, ktorý hlásil vadné sektory na disku), zálohovací systém s podporou obrazu disku , minimalistickú distribúciu na bežnú prácu (lubuntu alebo xubuntu) a inštalačky niekoľkých distribúcií (vrátane chmelOS).

DHCP server bežne prevádzkujete na domácom smerovači , ani u mňa to mu nie je inak. Naštastie mám na smerovači DIR-300 nahratý posledný build openwrt pod hlavičkou 3playGW.
Samotný DHCP server musí mať podporu “DHCP Options” , aby sme vedeli klientovi povedať kde sa nachádza bootovací server tftp a aký je názov bootovacieho súboru. Podľa mojich skúseností s týmto nastavením nemá problém ani mikrotik OS powered router

v terminali :

/ip dhcp-server option
add code=66 name=”tftp srv” value=X.X.X.X                                        –ip adresa Vasho servra TFTP
add code=67 name=”tftp fname” value=/opt/ltsp/i386/pxelinux.0    –cesta k boot
add code=17 name=”tftp root” value=/opt/ltsp/i386                          –adresar LTSP servera pre tftp
add code=43 name=”pxe option” value=PXEClient
Pri OpenWrt som žiaľ neuspel pri klasickom zadávaní DHCP options vo webrozhraní , nakoniec som ale našiel krátky post, ktorý pojednáva o bootovaní PXE klienta pridaním voľby dhcp-boot priamo do konfiguračného súboru /etc/config/dhcp

config ‘dnsmasq’
#[výstup vymazaný] – na posledný riadok prvej sekcie pridajte
option ‘dhcp_boot’ ‘pxelinux.0,boot-srv,192.168.0.2′

pxelinux.o – názov bootovacieho súboru v koreňovom adresáry tftp servera

boot-srv – názov(hostname) servra

192.168.0.2 – IP adresa servra

 

po zmene súboru zadajte v terminále

/etc/init.d/dnsmasq restart