Ubuntu 10.04 tenký-tučný klient

Nedávno som sa pri realizácii istého projektu strerol s nasadením bezdiskových počítačov ako tenkých klientov bežiacich na OS linux s rdesktop na windows terminal servery. Začal som sa problematikou tenkých klientov trochu zaoberať a objavil som veľmi zaujímavý projekt ltsp-server.

Inštalácia serverovej časti
Na server odporúčam použiť ubuntu 10.04 server alebo v prípade domáceho použitia kľudne desktop.
Základné néstroje pre inštaláciu tenkého klienta získame inštaláciou balíka ltsp-server

sudo apt-get install ltsp-server-standalone openssh-server

(ak chcete použiť dhcp na mikrotiku alebo inom routery kde sa dajú definovať dhcp options, inštalujte balík ltsp-server)
v prípade čerstvej inštalácie z cd v úvodnej obrazovke stlačte F4 a zvoľte Install an LTSP server

vytvoríme si testovaciu verziu z default nastaveniami

sudo ltsp-build-client --arch i386

na serveri treba pravdepodobne povoliť vo firewalle všetky služby ideálne pre podsiet pre tenkých klientov , minimálne portmap , tftp. rpc.mountd , rpc.statd

Každopádne po úspešnom nabootovaní máte tenkého klienta, ktorý využíva X server na strane servera,
takže všetky aplikácie spustené na tenkom klientovi bežia na serveri.Je to výhodné hlavne keď chcete
ako tenkého klienta použiť nejaký slabý počítač s malou pamäťou ram.
V tomto článku chcem ale priblížiť inštaláciu takzvaného tučného klienta, ktorý spúšta vlastný X server a taktiež
aplikácie, server sa využíva ako dátové úložisko pre klientov.
Pri inštalácii svojho klienta som vychádzal z návodu na help.ubuntu.com pre LTS server a pre tučného klienta
Počítač pre tučného klienta vyžaduje minimálne 1Ghz CPU a minimálne 512MB RAM
Takže pre ubuntu 10.04 som postupoval nasledovne:
vytvoriť adresár /etc/ltsp

sudo mkdir /etc/ltsp
sudo nano /etc/ltsp/ltsp-build-client.conf

pre edubuntu edubuntu-desktop

pre kubuntu kubuntu-desktop

pre ubuntu ubuntu-desktop

pripadne kubuntu-kde4-desktop

**********************************subor:ltsp-build-client.conf*******************************

# The chroot architecture.
ARCH=i386

# ubuntu-desktop and edubuntu-desktop are tested.
# If you test with [k|x]ubuntu-desktop, edit this page and mention if it worked OK.
FAT_CLIENT_DESKTOPS=”ubuntu-desktop”

# Space separated list of programs to install.
# The java plugin installation contained in ubuntu-restricted-extras
# needs some special care, so let’s use it as an example.
LATE_PACKAGES=”
ubuntu-restricted-extras
gimp
nfs-client
”

# This is needed to answer “yes” to the Java EULA.
# We’ll create that file in the next step.
DEBCONF_SEEDS=”/etc/ltsp/debconf.seeds”

# If you have Ubuntu Karmic, uncomment the following lines, so that you get
# LTSP 5.2 which is required for fat clients.
#EXTRA_MIRROR=”
#    http://ppa.launchpad.net/stgraber/ppa/ubuntu $DIST main
#”

# If you have Ubuntu Karmic, also uncomment the following lines, to install
# the necessary keys for the extra mirrors.
#APT_KEYS=”
#    /etc/ltsp/stgraber.asc
#”

# This uses the server apt cache to speed up downloading.
# You can’t use apt on the server while building the chroot, though.

MOUNT_PACKAGE_DIR=”/var/cache/apt/archives”

***********************************************************************************************
Pre potreby java:

sudo nano /etc/ltsp/debconf.seeds

************************

# Do you agree with the DLJ license terms?
sun-java6-bin   shared/accepted-sun-dlj-v1-1    boolean true
sun-java6-jre   shared/accepted-sun-dlj-v1-1    boolean true

************************

sudo ltsp-build-client

Po dokončení sa do klientského enviromentu dostanete cez

 sudo chroot /opt/ltsp/i386

(ja tam mám iba 386 tuším)
aby sa dalo všetko nainštalovať korektne treba pripojiť /proc a /sys súborový systém

mount /proc -t proc /proc
mount /sys -t sysfs /sys

môžme začať inštalovať :

apt-get install wine gimp gnome-office exaile grdesktop

….. čo koľvek chcete mať na tenkom klientovy

DHCP server options

Keď chcete použiť DHCP server na routri , ten samozrejme musí mať podporu DHCP options

priklad mikrotik

najprv pouzite sprievodcu pre nastavenie klasickeho dhcp, otestujte funkcnost

v konzoli zadajte

/ip dhcp-server option
add code=66 name=”tftp srv” value=X.X.X.X                                        –ip adresa Vasho servra TFTP
add code=67 name=”tftp fname” value=/opt/ltsp/i386/pxelinux.0    –cesta k boot
add code=17 name=”tftp root” value=/opt/ltsp/i386                          –adresar LTSP servera pre tftp
add code=43 name=”pxe option” value=PXEClient
Ostatne routre (napr. OpenWRT powered)

DHCP code     value                   popis

66                   X.X.X.X               IP adresa servera pre klientov

67                   /opt/ltsp/i386/pxelinux.0

17                   /opt/ltsp/i386

43                   PXEClient